ScanNav Documentation

Table of contents: 

Table of contents: 1

INTRODUCTION: 2

Disclaimer: 2

Required configuration: 3

Package Installation: 3

Generalities: 3

Multi-Windows functionality: 4

General layout of the different tool bars: 4

On line help. 5

Scrolling and zooming around the screen: 6

Scrolling can be performed in several ways: 6

Zoom forward and backward can be done by: 6

Selection tool : 8

How do the ,  and  tools work?: 8

Charts Workshop: see WorkShop.htm... 8

Navigation mode: see Navigation_Mode.htm... 8

Commercial charts compatibility: 8

BSB Charts and other Maptech formats: 8

SoftChart charts : 8

EasyNav charts: 8

Land Topologic IGN charts : 9

Aerial photography of the French coast: 9

USGS/DRG charts: 10

Obtaining a License: 10

Price and payment facilities. 11

Limitations of the Demo version: 11

Obtaining a free temporary license. 11


INTRODUCTION: 

ScanNav is a navigation program that enables you to:

-SCAN large charts by pieces with a standard desktop scanner, merge the pieces and georeference the resulting charts using the workshop mode. ScanNav is of course also compatible with several standard chart formats. You can therefore mix charts of different origins, either commercial or home made, in the same charts library, which gives you a great latitude.

-NAVigate using these charts and a GPS with an NMEA output. Charts are then loaded automatically on screen, and can be zoomed in or out at wish. ScanNav will load the charts the more appropriate to the zoom level.

ScanNav not only uses the GPS information to position the boat on the screen, but it can do a lot more by interfacing other instruments such as the depth sounder, loch, wind indicator, or compass which are displayed in various repeaters and kept in the track for future analysis.

It also integrates management of Danger areas, waypoints and routes with approach alarms, upload and download of routes, tracks and waypoints to/from the Garmin GPS, as well as holding an automatic graphical journal all information being kept in the track..

An optional weather forecast module using the standard GRIB format files enables you to display different types of weather forecasts overlaid on top of the map.

Any suggestions are welcome. You can email them to me at postmaster@scannav.com. You can also post your suggestions on the users forum accessible at http://fr.groups.yahoo.com/group/scannav. This forum lets users help each other, and also is a vector for diffusion of new functionalities as prereleases.

Some adaptations can be done to match specific needs. Please contact  me directly at postmaster@scannav.com for further details.

Disclaimer:

Navigation software whatever they are can always fail. It is your responsibility to make sure you have and can use all necessary documents and papers charts on board to cover your navigation area.

ScanNav is a navigation help tool. It is in no way meant to substitute to official paper charts and other navigation documents, as well as the skills and interpretations of an experienced captain.

No guaranty whatsoever can be given that ScanNav will be exempt of errors or bugs, that calculations are 100% accurate or that it should meet all your needs. Despite the fact that all has been done to avoid them you might find bugs or miscalculations. Nevertheless, if you report me your problems or requests, I will do my best to satisfy you.

You are using ScanNav at your own risks, and in no events shall the author be liable for any loss or damage of any sort and any party.

Be also aware that the Global Positioning System (GPS) might have some random precision failures due to poor satellite reception and depending on the receptor quality, that might lead to erroneous - thus dangerous - interpretation. This in spite of the suppression of SA (Selective Availability, or voluntary error generated by the US Army) since May the 2nd 2000.

Required configuration:

ScanNav runs on PC platforms installed with Windows 95/98/NT/2000/XP. The smallest tested configuration in navigation mode was a 486 with 12-Mb memory. But for the Workshop mode I would recommend a minimum of 64Mb or more if you want to stitch large charts (it would work with less, but much slower, this also depends on your version of windows). Make sure your disk space doesn't become low on your system unit so as Windows can extend the virtual memory through swap space.

Actually, ScanNav can run on small configurations, but the biggest, the better, especially considering memory in workshop mode.

Some of the latest functionalities are a bit more consuming in terms of cpu and memory resources. It is the case for example of the “Antialiasing” option that improves the on screen rendering of charts, but can slow down the pc, and is not always effective on old pc configurations. You can deactivate this option in the “chart loading” tab of the preferences (accessible through the “File” menu). The “filled area” mode in the grib weather module is also highly consuming on old pc configurations. Please refer to the grib documentation for further details.   

Package Installation:

The package and documentation being updated regularly please make sure to have the latest version which is downloadable at http://www.scannav.com. The site has a history page that enables you to have a quick view of the last enhancements.

The package can be downloaded either as a single file, or split in several files so as to limit downloading problems or to hold on floppies. Once downloaded, the installation process follows the windows standard scheme. Just double-click on the downloaded file and follow instructions. The default installation is “c:\ScanNav”, but it can be changed at wish.

Installing ScanNav doesn’t modify anything on your computer, and doesn’t add any DLL to windows. The only registry entries used are "HKEY_LOCAL_MACHINE\Software\Marc Lombard\ScanNav" and “HKEY_CURRENT_USER\Software\Marc Lombard\ScanNav”. These keys will remain on your system after un-installation so as to keep your parameters between different installations, but you can manually remove them without any risk for other applications.

Generalities:

ScanNav is composed of two different parts:

·        Charts Workshop: (scan, georeferencement...)

·        Navigation usage 

On the first use, ScanNav opens by default in navigation mode. On next sessions, ScanNav will open in the last used mode. To switch between both modes, you have to open a new window in this mode using the “File” menu:

These two modes have nevertheless a certain number of common aspects:

Multi-Windows functionality:

Be careful, ScanNav is a multi-documents application. This means you can open several “Documents” or working windows independently from each other. In this case, if you open several times the same chart in separate documents, it will be present several times in memory. That’s what happens if you use “Open in new window” or “New”. This can be interesting in some cases but bring more confusion than functionalities, especially in navigation mode.

The alternative is to open several windows of the same document, in Workshop or in navigation mode, which lets you view different areas of the same chart or library, at different scales, but without duplicating the data. To do this, you can use the “New Window” of the “Window” menu.

You can then arrange windows in Mosaic or Cascade inside the main window.

General layout of the different tool bars:

Three tool bars are present by default in ScanNav:

 and  are used in both modes

 and  are used in workshop mode.

 and  are used in navigation mode.

In order not to overload the dislay with unused icons, some buttons are not present in the navigation mode default toolbar. These are  . To include them in your interface, you have to create a new toolbar (see further the creation of « custom toolbars »)

Each bar can be placed where you want, docked on one of the four edges of the screen, or as a floating separate window. To move a toolbar you just have to click on its border (or in any region without a button) with the mouse's left button, and drag it where you want it. It will appear vertical or horizontal, depending if it's attached to a vertical or horizontal edge of the main window.

By clicking with the mouse’s right button on a tool bar, and selecting the « Customise » entry of the menu, you can open the following dialog box to add or remove buttons from the toolbar. To reset the toolbar to its default buttons, just select the « reinitialize » entry of the same menu.

The list on the right represent buttons that are already present in the toolbar, and the left list those that can be added to it. You can add or remove buttons from the toolbar by selecting them in the appropriate list and clicking on “Add” or “Remove”. The order of buttons in the toolbar can be changed using the buttons on the right. You can also click and drag them to the right position. “Reinitialize” resets the buttons in the toolbar the way they were on entering the dialog.

You also have the possibility to add any number of custom toolbars, with a few extra buttons that do not appear in standard bars. This can be done using the « Add new toolbar » of the above menu, or the « Custom bars » entry of the « View » menu.

·        To create a new bar, click on « New », and give a name to the bar. It will be created including all the available buttons by default, and the above dialog will open. You will just have to remove buttons you don’t need in this toolbar.

·        To temporarily hide a toolbar without destroying it, just uncheck the check-box on the left.

·        To suppress a custom toolbar, select the entry and click « Suppress »

On line help

On line help is directly available from ScanNav. In order to use it, you must have installed an HTML file browser such as Netscape or Internet Explorer or any other (the one you're using right now would do).

On line help can be displayed in several ways:

·      By pressing the F1 keyboard key to open the help associated with the dialog box currently in use

·      Using tool  of the main window. The mouse cursor changes temporarily. By clicking on any tool or double-clicking on a menu entry you get the associated help.

·      You can also select the “Help topics” in the “?” menu to go at the beginning of the help file.

Scrolling and zooming around the screen:

Scrolling can be performed in several ways:

·        With the keyboard:

Use the keyboard arrows to scroll up/down/to the left/to the right.

·        With the scroll bars:

-These scroll bars can be activated or deactivated through the "Scrollbars" entry of the "View" menu, this letting you gain some space for chart viewing if you have a small screen.

-By clicking on the scrollbars' arrows, you scroll by a 10th of the screen

-By clicking outside the square, you scroll by one screen

-By clicking in the square, you can move it to a given relative position. Nevertheless, in navigation mode it is not recommended to use this capability, as the working area is "virtually infinite", and it might be difficult to find your way back, as the relative region represented by the scroll bars change as the charts are loaded.

·        By clicking on the inside edges of the window:

When you move towards the edges of the main window, the cursor changes to double arrows oriented North, South, East, West, NE, NW, SE, SW, depending which side or corner you're approaching. If you then click with the mouse's left button, you scroll of a 10th of the screen towards the arrows direction.

·        With the  tool:

When this tool is selected, you just have to click on the screen with the mouse's left button and drag it.

·        With the mouse's center button:

For those who have a 3 buttons mouse (or an Intellimouse), you can use the middle button as a shortcut to the  tool. This way you can scroll very quickly without changing tool. If you have a mouse wheel, just press it down vertically as if it was a button instead of rolling.

Zoom forward and backward can be done by:

·        Using the mouse wheel:

If you have a mouse wheel, you can use it to zoom forward or backward by rolling it forward or backward. The chart will also be re-centered at the mouse’s position at the same time.

·        Using the keyboard:

Use the + and - keys to zoom forward or backward on the cursor's point.

·        Using the  buttons:

Zooms forward or backward by a level of 2 from the center of the screen.

·        Using a contextual menu:

By clicking with the mouse's right button anywhere on the screen, a menu shows up. You just have to select one of the entries "Zoom Forward" or "Zoom Backward" to zoom forward or backward on the cursor's point.

·        Using the  tool:

When this tool is selected, click on a point in the screen and drag the mouse to define a rectangular region. When you release the mouse, the defined rectangle will be zoomed to fit in the screen.

·        Using tool :

This tool lets you define the scale as a true distance represented by the "<-------->" symbol. This distance can be chosen in a list (by clicking on the left arrow), or directly by entering the desired value in the appropriate field and typing the <Enter> keyboards key. This value is then automatically added to the list so it can be recalled easily later on. You can choose (in the right list) the unit between nautical miles (NM), kilometers (KM), or meters (M) multiplied or not by 10.

Distance taken in account is at the center of the screen. It is updated as you move around the map.

·        You also can move directly to a precise place at a given scale through the tool activated with the "Visible Area" entry of the "Operations" menu. This opens the following dialog box:

 

You just have to enter the position you want to move to, and the horizontal distance of the area you want to view. This is done in the same manner as for the previous tool, except for the distance taken in account: here it is the distance shown from the left to the right of the screen.
"Apply" lets you move to the position at the given scale without exiting the function, and "OK" does the same but also exit the dialog.

Selection tool :

This tool lets you select one or several elements on which the further operations will take place (suppressions, adjustments…)

·        A single click on an image or object selects it and deselects any previously items.

·        If you press the Ctrl key at the same time, the item is added or removed from the selection list.

·        By clicking and maintaining the mouse's button down while dragging it, you define a rectangular region. All elements included completely in this region will be selected.

How do the ,  and  tools work?:

These tools temporarily inhibit the current function, in both Workshop and Navigation modes. This lets you change the selection on which the current tool's action is going to take place (for example adjustment), or scroll and zoom in or out without quitting the current tool. To continue working with the current tool, you just have to deselect these alternate tools.

Charts Workshop: see WorkShop.htm

Navigation mode: see Navigation_Mode.htm

Commercial charts compatibility:

BSB Charts and other Maptech formats:

ScanNav is fully compatible with the BSB format charts (.kap and .cap extentions), including latest releases 4.0 and 4.1. This format is the propriety of Maptech Inc (http://www.maptech.com), which releases these "ready to use" maps at an affordable price. ScanNav is now an official distributor of Maptech charts and we can therefore provide them. Please refer to the ScanNav web page or contact us for more details.

Maptech also releases other chart formats: (Trucharts PCX (.hdr suffix), RML (.rml suffix) and TIFF files (.tif, .nau and .aer suffixes). These are also supported in ScanNav, but the BSB is preferred as it has been optimized, and more tested.

Note: For copyright reasons, when printing or exporting Maptech charts in another format, these are incrusted with a copyright text. The result is still handy for personal use.

USGS/DRG:

ScanNav permet l'import des cartes USGS DRG. Celles-ci sont des cartes topographiques et leur utilité est limitée pour la navigation maritime. Cependant, elles sont intéressantes, car elles sont dans le domaine public, et couvrent la totalité des USA  dont les côtes. Mais ce ne sont pas des cartes adéquates pour la navigation (manque de détails au niveau des écueils) . Plusieurs sites existent ou vous pouvez télécharger gratuitement ces cartes. Par exemple: http://mcmcweb.er.usgs.gov/drg/avail.html#online . Attention, ces cartes sont au format TIFF non compressé, et peuvent être très volumineuses. Vous gagnerez beaucoup (voir énormément) en les transformant en cartes ScanNav, tant au niveau du temps de chargement qu'au niveau de l'espace disque utilisé (faire import du fichier .tif, et ensuite exporter au format ScanNav .map). Il est également conseillé d'effectuer une réduction de couleurs avant d'exporter au format ScanNav.SoftChart charts :

ScanNav also supports natively charts with extention NOS/GEO that are released by SoftChart. Please refer to their web site at http://www.softcharts.com/ for further details.

EasyNav charts:

ScanNav can import some of the EasyNav charts.

The EasyNav charts (at least the ones that have been tested) are composed of several files gathered in a "cartes" directory.

·        ".car" files: these are the image files in BMP format

·        ".tar" files: these are the georeferencement files (nothing to do with the Unix .tar files…)

·        ".par" files: I didn't find the utility of these files

To insert an EasyNav chart, use the "Insert" function, and choose the "EasyNav charts (*.car)" file type. Select one or several files (through the "Shift" and "Ctrl" keys), and click on "Open".

If you do this in Navigation mode, the maps will adjust together automatically as you import them.

If you are in "Workshop" mode, maps inserted in one step will be adjusted together, but those inserted in two different successive "import" operations will be on top each other. You just have to ask ScanNav to adjust them together by selecting All Charts ("Select All" in the "Edit" menu, or "Ctrl A" keyboard shortcut) and applying the "Adjust to Reference" function of the "Operations" menu. All the pieces will then adjust together. You will then just have to save the chart as a ScanNav chart. It is strongly recommended to do a color reduction to 256 or 16 colors before saving so as to optimize the chart.

Land Topologic IGN charts :

It is possible to order topologic charts to the French IGN in Tiff/Tfw format. They can then be used in ScanNav using an optional tool to convert. For further details please contact postmaster@scannav.com

Aerial photography of the French coast:

The French « L’inventaire permanent du Littoral » has a free download service of aerial photography of the French west coast. The web site is accessible at  http://siglittoral.test.application.equipement.gouv.fr/ ( click on « Orthophotographie » then on « consultation et téléchargement des dalles »)

The actual coverage goes from the Spain border up to Concarneau, the Gironde river included.

Files are downloaded in the MrSid format. In order to use them in ScanNav, you will need to convert them using an optional utility.  For further details please contact me at postmaster@scannav.com

Warning : These photos are not for navigation usage. They nevertheless are of very good precision, and let you have a very good idea of the land configuration and anchorage areas. All photos having been shot at low tide.

These photos use the Lambert projection, and although it is possible, it is not recommended to mix them in the same chart library with nautical charts that use the Mercator projection. Indeed, the two projections are incompatible and cannot fit perfectly together on the screen, which can be disturbing for non advised users. It will be better to build two different chart libraries, one for nautical, and one for aerial photos, and switch between them according your needs (refer to Charts library management).

USGS/DRG charts:

ScanNav can import USGS/DRG charts. These are Topo maps of the USA, and their usage is limited for navigation usage. The interesting thing is that they are public domain and cover all of USA, including shores. THEY ARE NOT ADEQUATE FOR NAVIGATION, but can be used for trip planning. Several sites exist where you can download them for free. http://mcmcweb.er.usgs.gov/drg/avail.html#online is one of them.  Warning: these charts are in TIFF format and not compressed. So they can be quite big! You will gain a lot in disk space AND in time for loading by exporting them as ScanNav maps. It also is recommended to make a color reduction to 16 or 256 colors before exporting.

Obtaining a License:

ScanNav is downloadable at http://www.scannav.com. You can try it for free, make your friends try it (it is strongly recommended!), and if you’re convinced, and to be able to use the full functionalities, you must fill up the Registering formula and send it by mail to postmaster@scannav.com. Proceed as follows:

·        In ScanNav, open the « Register » entry of the « ? » menu.

·        Fill up all the input fields.

·        If your pc is connected to Internet, you can just press the “Send by mail” button. Your default mailer will open with a prepared message and the appropriate attached file. You can complete the message with your questions/comments before sending it.

·        If not connected, press the « Save » button. A File Selector appears to choose a file where the registering information will be saved. This will be by default the file named « ScanNav.cfg » that will be in the same directory as the ScanNav.exe program, but you can choose to put it anywhere you want. You will then need to transfer this file (using a floppy or any other way) to another pc connected to Internet, in order to send it by mail to postmaster@scannav.com as an attached file. Please mention  « ScanNav License » in the object field.

·        You can also visualize or Print these informations.

·        At reception of your payment, you will get by Email a file named « firstname_lastname.lic ». with instructions on how to activate.

·        You also can send a print out of the ScanNav.cfg file (or preferably a floppy) by regular mail to:

Marc Lombard
15 Allée de la Lande
33610 CESTAS
FRANCE

You will then receive by regular mail a floppy with the “firstname_lastname.lic”  file.

Price and payment facilities

Price and payment facilities being subject to change are indicated on the web site http://www.scannav.com. You can also contact me at postmaster@scannav.com for further information.

Limitations of the Demo version:

The evaluation version has all the application’s topics included. Nevertheless, a few limitations are introduced:

·        A text stating the version is unregistered is displayed on screen in transparency mode

·        Any raster image generated by the non-registered version of ScanNav will be incrusted with a text copyright.

·        A copyright message appears every 10 minutes.

·        ScanNav exits after one hour running.

·        The demo version will expire after one month trial. It is nevertheless possible to request a temporary license in order to continue testing.

·        The weather forecast Grib module is limited to the few samples coming with the package. It is nevertheless possible to test a specific file on request. In order to do this, please send a mail to postmaster@scannav.com with the grib file attached. We will send you a code to enable this file to be read in the demo version.

Obtaining a free temporary license

All these limitations (except the time limit) can be bypassed by asking a FREE temporary license. To do so, just follow the instructions of the Obtaining a license chapter and send me the registration file by Email specifying you want a free temporary license.

Introduction

Back to ScanNav's Main page